Sportbike Racing Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
24 Posts
Discussion Starter · #1 ·
Hey everyone, i am having a problem with my 99 Ducati M900
There is some sort of electrical problem, when i turn the key to "on" nothing happens, and yes i have checked the battery. if i turn the key back and forth 20 or 50 times it comes on sometimes. i can also hear a clicking of some kind underneath the seat when i turn the key. if i turn the key to "park" the dash light comes on and so does the tail light. please help i need to ride very badly.
 

·
Registered
Joined
·
7,824 Posts
dunno...i had a problem one day comin home from school. came over a small ridge and all of a sudden, all gauges stopped reading-back to zero- headlight cutout and other things....thought it was a major engine problem cause it would bog in anything higher than first. takin the bike apart i found a broken tailight-replaced it, then went through the fuse box and replaced the busted fuse- guess the tailight arched out on me, problem solved....doesn't sound remotely as serious as what you're talking about though....sounds electrical in nature though, hope the more useful members of this site can help:)
 

·
Registered
Joined
·
1,443 Posts
Make sure your battery is fully charged, sometimes even one that is a little less than full can has some serious effects on the bike. On my 900rr, my battery was dying and it killed the ignition coils, so I couldn't get a spark.

If it's not that, you might have a bad wire in the ignition switch/assembly.

<font color=red>follow the leader..."he's on a honda, mine!"</font color=red>
 
1 - 3 of 3 Posts
Top